Press "Enter" to skip to content

SAP BASIS – Pasos para actualizar librerías de SAPUI5

snatic_k8ot5v 4

Lo primero es saber que versión tenemos actualmente y para ello es necesario visitar el siguiente link:

http://<server>:<port>/sap/public/bc/ui5_ui5/index.html

Al visitar este link tendremos algo como lo siguiente:

Donde claramente se nota la versión que actualmente tiene el sistema que es la 1.30.1

Ahora debemos verificar la versión mas actualizada de esta librería, para ello ir al Market Place de SAP:

http://support.sap.com/swdc

Visitar la opción Search for Software e ingresar SAPUI5 CLIENT RUNTIME:

Del resultado dirigirse hasta la sección de descargas y descargar el parche más actual que exista.

Importante se debe incrementar el parámetro rdisp/max_wprun_time ya que el proceso toma más tiempo de lo normal, para esto ir a la transacción RZ11 e ingresarlo, después presionar el botón change value y asignarle no menos de 12000 y realizar el guardado.

El programa que se encarga de actualizar la versión es el /UI5/UI5_UPLOAD_PATCH_TO_MIME para tener el más actualizado es requerido revisar las notas

2058624, 2103131, 2135804, 2118663, 2150275.

Se requiere crear una orden de transporte tipo Workbench para ubicar los cambios:

Ejecutamos el programa /UI5/UI5_UPLOAD_PATCH_TO_MIME

Después rellenamos la información solicitada, incluida la orden de transporte y el ZIP descargado del MP, es sugerido hacer una prueba con la marca de test, esto puede tardar un tiempo antes de responder.

Se debe iniciar por la versión más nueva que tenemos aplicada y proceder después a las versiones que le prosigan, después de un tiempo responderá con los cambios realizados, es importante quitar la opción de test mode.

Al finalizar si consultas nuevamente la página de la librería, notaras el cambio que se ha realizado:

  1. Felipe Donoso Felipe Donoso

    Daniel te quería consultar con respecto a que versión tengo que subir si mi sistema esta en la versión 1.22.14 ?

    • Hola Felipe, lo puedes validar con marketplace, busca en download «UI ADD-ON FOR SAP NETWEAVER» y ubica la versión que se adapta a tu SAP netweaver:

      La siguiente es la ruta donde buscar: UI ADD-ON FOR SAP NETWEAVER/ -> SAPUI5 CLIENT RUNTIME/ ->
      SAPUI5 CLIENT RUNTIME 1.00/

      Ahi puedes validar las version que estan arriba de la que mencionas que son soportadas, es importante que esta actividad la realice un basis.

      Saludos

      • Felipe Donoso Felipe Donoso

        Me funciono el procedimiento muchas gracias.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *